El error RCE sin parches en el proyecto dompdf afecta a los convertidores de HTML a PDF

Conversores de HTML a PDF Noticias

Los investigadores han revelado una vulnerabilidad de seguridad sin parches en «dompdfun convertidor de HTML a PDF basado en PHP que, si se explota con éxito, podría conducir a la ejecución remota de código en ciertas configuraciones.

«Al inyectar CSS en los datos procesados ​​por dompdf, se puede engañar para que almacene una fuente maliciosa con una extensión de archivo .php en su caché de fuentes, que luego se puede ejecutar accediendo desde la web», los investigadores de Positive Security Maximilian Kirchmeier y fabian braunlein dijo en un informe publicado hoy.

En otras palabras, el defecto permite una parte malintencionada para cargar archivos de fuentes con una extensión .php al servidor web, que luego se puede activar mediante el uso de un Vulnerabilidad XSS para inyectar HTML en una página web antes de que se represente como PDF.

Conversores de HTML a PDF

Esto significaba que el atacante podría potencialmente navegar al script .php cargado, lo que permitía efectivamente la ejecución remota de código en el servidor.

Esto puede tener consecuencias significativas en los sitios web que requieren la generación de PDF del lado del servidor en función de los datos proporcionados por el usuario, como compras de boletos y otros recibos, particularmente cuando las entradas no se desinfectan adecuadamente para mitigar las fallas de XSS o si la biblioteca está instalada en un lugar público. -directorio accesible.

Según las estadísticas de GitHub, dompdf se usa en casi 59 250 repositorios, lo que la convierte en una biblioteca popular para generar archivos PDF en el lenguaje de programación PHP.

Las versiones de Dompdf 1.2.0 y anteriores que se encuentran en un directorio accesible desde la web y tienen activada la configuración «$isRemoteEnabled» deben considerarse vulnerables. Sin embargo, las versiones 0.8.5 y anteriores de la biblioteca se ven afectadas incluso cuando esta opción se establece en falso.

Aunque la vulnerabilidad era reportado a los mantenedores del proyecto de código abierto el 5 de octubre de 2021, los desarrolladores aún no han proporcionado un cronograma de cuándo se espera que se implementen las correcciones.

«Las vulnerabilidades de seguridad a menudo ocurren debido a decisiones (de diseño) basadas en suposiciones incorrectas sobre componentes subyacentes o interconectados», dijeron los investigadores. «Actualice dompdf a una versión más reciente y desactive $isRemoteEnabled, si es posible para su caso de uso».

David
Rate author
Hackarizona