Múltiples fallas descubiertas en el sistema de base de datos OLAP de ClickHouse para Big Data

Base de datos OLAP de ClickHouse Noticias

Los investigadores han revelado siete nuevas vulnerabilidades de seguridad en una solución de sistema de gestión de base de datos de código abierto llamada ClickHouse que podría armarse para bloquear los servidores, filtrar el contenido de la memoria e incluso conducir a la ejecución de código arbitrario.

«Las vulnerabilidades requieren autenticación, pero pueden ser activadas por cualquier usuario con permisos de lectura», Uriya Yavnieli y Or Peles, investigadores de la firma DevSecOps JFrog, dijo en un informe publicado el martes.

«Esto significa que el atacante debe realizar un reconocimiento en el objetivo del servidor ClickHouse específico para obtener credenciales válidas. Cualquier conjunto de credenciales servirá, ya que incluso un usuario con los privilegios más bajos puede desencadenar todas las vulnerabilidades».

La lista de siete defectos está a continuación:

  • CVE-2021-43304 y CVE-2021-43305 (Puntuaciones CVSS: 8,8) – Defectos de desbordamiento del búfer de almacenamiento dinámico en el códec de compresión LZ4 que podrían conducir a la ejecución remota de código
  • CVE-2021-42387 y CVE-2021-42388 (Puntuaciones CVSS: 7.1) – Errores de lectura fuera de los límites del montón en el códec de compresión LZ4 que podrían provocar una denegación de servicio o una fuga de información
  • CVE-2021-42389 (Puntuación CVSS: 6,5): una falla de división por cero en el códec de compresión Delta que podría provocar una condición de denegación de servicio
  • CVE-2021-42390 (Puntuación CVSS: 6,5): una falla de división por cero en el códec de compresión DeltaDouble que podría provocar una condición de denegación de servicio
  • CVE-2021-42391 (Puntuación CVSS: 6,5): una falla de división por cero en el códec de compresión Gorilla que podría provocar una condición de denegación de servicio

Un atacante puede aprovechar cualquiera de las fallas antes mencionadas mediante el uso de un archivo comprimido especialmente diseñado para bloquear un servidor de base de datos vulnerable. Se recomienda a los usuarios de ClickHouse que actualicen a la versión «v21.10.2.15-estable» o posterior para mitigar los problemas.

Los hallazgos llegan un mes después de que JFrog revelara detalles de una vulnerabilidad de seguridad de alta gravedad en Apache Cassandra (CVE-2021-44521, puntaje CVSS: 8.4) que, si no se aborda, podría ser objeto de abuso para obtener la ejecución remota de código (RCE) en los afectados. instalaciones.

David
Rate author
Hackarizona